Node Mining Problems

Hello all, Greetings and Salutations!
I honestly hope someone can help me and point out where I’m going wrong. I am unable to mine to my node. When I use the standard dero miner, I get an error message stating “DERO BLOCKWORK COULD NOT BE DECODED SUCCESSFULLY “. When I use Astrobwt, I get an error message that states"FATA[0000] Wallet address is invalid: err Address is not complete.”
I have 4 registered wallets, two I created before setting up my node and two I created after setting up my node. Regardless of whichever address’s I use, I still get the same error messages. My node and wallet(s) are fully synced, I have the dero as a priority node, I launch my daemon with the integrator address, and I have copies of the .db and .db.bak files in my mainnet folder as well as my main dero node folder. Also, I’m mining to my node.
I found an old article on this forum were someone had a similar situation but given the recent snafu the Dero network experienced, some of the solutions recommended were outdated. I’ve also used the " – help” options and rewrote .bat files as it suggested to no avail. I’m not a coder, just an ordinary schmuck lost in the woods, probably in over my head. If someone can point me in the right direction you’d have my everlasting gratitude and appreciation. I have faith in the Dero project ever since I first learned of it, I really want to keep that faith.