Stargate cli wallet can't get it registered

i got the wallet set up and when i press 4 to register it never goes true

Hi. I have a similar problem. I am running a full node on windows. The node is synced up. When I check status, the mainnet height is the same as the numbers at the beginning of my node command line. I’ve checked to make sure I am running the latest downloads.

I get a TX number after I click “4” to register, but the wallet does not shift over to being registered. I’ve let it run for 24 hours after getting the registration request tx number. I tried creating a new wallet and running through the process again. I got the same result. After receiving a tx number for the registration request, the wallet never switched over to being registered.

Do I have to leave the wallet and node running after submitting the registration request… and leave it running until it becomes registered or can I shut down the node/wallet and come back to it later. Is the registration request still pending?

I did see the thread that suggested creating a web wallet and then restoring it on the CLI. I could be wrong, but my impression of that process is that it is less secure than creating the wallet on your local machine. Am I correct or incorrect.

Any help or recommendations would be greatly appreciated.

Thank you.

If you wallet shows green for heights and is not 0/X, you’re good. If just referring to the menu options, hit enter or reopen the wallet and should be fine.

If your height is not the same as at , wait for local daemon to sync or run CLI with --remote to use a fully synced node and register that way.

Thank you for the help. I was able to get the wallet to register. I appreciate it.