Web Wallet problem & register blockchain

Hello all,

I was in DERO 2 years ago, that time the web wallet was working well and fast, no need to have technical knowledge. Now I want to come back, I’ve tried the new Web Wallet (Stargate thing) and it doesnt sync anything. Im talking about this : https://wallet.dero.io/

Block height is blocked to 0, its been 5 hours im waiting. I clicked like thousand times on “register now” in the Register to blockchain section, nothing happen (5 hours im waiting).

Does this wallet actually work/sync or not ?

When I try to find solution on internet I just understand nothing about what people are talking about. I just want a synced wallet to receive and send coins thats all.

On the website it tells me to download a command line wallet but im not an IT guy and I don’t want to spend hours understanding command lines and all errors that will happen to me whatever.

Does the web wallet actually work or not ?

Thanks you in advance and sorry for the bad english

Best regards.

EDIT : Im using Firefox latest version on Windows 10 latest version

I couldn’t get web wallet registration to work on either Mac or PC with various different browsers on both (FF, Chrome, Brave).

Registration just never seems to happen.

The web wallet does work though, you just have to have a registered address to be able to use it and the only way to do that right now is to download the cli version of the wallet, run it with the --remote option and then follow the instructions for creating a new wallet in the docs. It honestly not difficult at all and doesn’t take long.

The address will register after a short while and then you can import the seed phrases from this newly registered address into the web wallet. Then the blockchain will sync and you can use the web wallet as normal. It won’t sync until you have a registered address on there though.

You will never have to use the CLI wallet again if you don’t want to, you only need it to register an address.

Hope that helps.


Thanks you for your answer.

Where can I find a simple doc for the CLI software, something that will not burn my eyes ? Since I just want to register.

Also, if I understand, the DERO on “atlantis thing” are not the same DERO that are in the “star gate thing” right ? One day the DERO on atlantis will get useless/not useable right ?

Do the “stargate thing” will eventually get replaced again ?

I like to buy good projet I trust, and hodl, but I don’t like to follow on twitter and all these toxic places to get up to date, and I don’t like to have to move my money before it get obsoletes. I already lost some ERC20 like that…

Best regards

I have found the documentation on the website, I will give it a try by myself, it doesn’t look that bad indeed.

I have tried the CLI software, but of course it also doesn’t work.

The registration doesn’t work, I have tried it two times…

Did you start it with the remote option?

dero-wallet-cli-windows-adm64.exe --remote

That was the only thing that worked for me (on Win10), couldn’t even get it to register an address with the cli wallet on a Ubuntu machine.

There is definitely a problem here somewhere, too many people are reporting the same issue. Honestly, the remote thing works. Try quitting the wallet and restarting it again, choose your wallet.db file and open it, then hit 4, it might take 20 minutes or so, don’t close the app just leave it open after choosing option 4 and it should eventually do it.


I have tried running my own node with the CLI, its a solution found on the forum.

I told me the registration was successfully dispatched yesterday before I went to sleep. After 12 hours, I have tried to register again (I didn’t stop the computer and CLI) and it again tell me the dispatching was successful. But I am still not registered in fact…

The CLI doesn’t even work. I start to lose faith in the projet, since nothing work in fact.

I restarted the wallet CLI, and after 12Hours after registration successfully dispatched, I am still not registered…

This coin will never be adopted I guess. Monero is very long to synchronize, as well as Pirate Chain, but at the end it synchronize by itself without need of IT knowledge. While this DERO, Im litterally using my command line (which will disgusts most people) and it doesnt even work…

So I can’t store any DERO in a non custodial way, so not my keys not my coins :confused:


I finally succeeded !

I removed the .exe on your command line and it worked, and now it seems that my account is registered.

To help other people that could seek help here :

-Running my own node didn’t help
-you need to remote connect to a node
-right command is : dero-wallet-cli-windows-adm64 --remote

You also need to have a good internet connection, it was impossible to register while I was downloading something else in the same time.

Best regards

1 Like

Its not solved in fact…

I will get crazy.

When I launch my wallet locally, without REMOTE, it says my account is not registered. When trying to connect my miner to my own node, it marks ERROR MINER NOT REGISTERED on my daemon node.

When I use the remote command for the wallet, it says I am registered.

Yes, the wallet needs to connect to a node to sync. When you use the --remote option it’s using the Dero teams node (I assume). If you run your own node locally it should also work but it never did for me. SAme goes for when I tried to connect it to my remote node, didn’t want to know at all.

My advice is to forget the cli wallet now you have a registered address. Take your seed phrases and import them into the Dero Web Wallet and use that one instead.

Your wallet will say registered against an unsynced node when it gets to the height in which you registered. Otherwise it doesn’t exist in your current derod sync , and this is unregistered at your instance.

By using remote you are connecting to an in-sync node and registering properly. To do this against your local node you’d also need to be fully synced. But either way, remote or local full sync and registering works the same. For now, since you registered against remote, wait until your local node is in sync and then you can use your wallet accordingly to your daemon.

If you need to utilize for tx etc, you can run with remote node and proceed as usual until your local daemon is in sync.

So you mean I always need to run a node by myself or remote connect to a node if I want to use the CLI wallet to do tx ?

Yes. As I understand it ,unlike most other cryptocurrencies, the Dero cli wallet isn’t also a daemon so it needs to connect to one that is sync’d up in order to interact with the blockchain.

What is strange is why a master Dero node (or whatever is being connected to via the --remote option) isn’t hardcoded into the wallet so it just boots up with that remote option as default? It would certainly make things easier for newbies as the cli wallet would work right out of the box.


Thanks you for answer

It has been solved.

To help other people that could seek help here :

-Running my own node didn’t help
-you need to remote connect to a node
-right command is : dero-wallet-cli-windows-adm64 --remote

You also need to have a good internet connection, it was impossible to register while I was downloading something else in the same time.

Best regards

Yes, totally agree… simply the REGISTRATION funciton appears to be not activated in the programming side… i tried registering 3x over a few weeks via the CLI wallet, then again today via the NEW webwallet https://wallet.dero.io/ and after clicking on the REGISTRATION link on the left, then clicking the register button on that page, nothing works from that button. there is no action or confirmation or error message. It is not activated on the developer’s side i think… There is no screen shot necessary. Follow those steps and you will see what we all are complaining about.

Post some screenshots/errors of your problems.

I am also having the same issue with the web wallet. I have tried multiple times (and two wallets), different browsers, disabling all add-ons and when I click register, it does nothing. I’ve clicked and let it sit for hours, and still nothing. It seems the registration button is empty. Some help would be appreciated.

I would share a second screen shot, but I can’t get passed this page.

PS. I’m not sophisticated enough to attempt a CLI wallet. I want to use the wallet the same as I did for Atlantis. Basic but straight forward.

Press register and wait for some hrs. Height will change from 0 to match RHS number.