Cant mine with pixel 6

hey hi I want mine with my android phone
I did these

https://docs.dero.io/rtd_pages/basic_androidmining.html

but I just get this error

ERROR   miner   Blockwork could not be decoded successfully        {"blockwork": "", "n": 0, "job": {"jobid":"","difficulty":"","difficultyuint64":0,"height":0,"prev_hash":"","epochmilli":0,"blocks":0,"miniblocks":0,"rejected":0,"lasterror":"","status":""}}

What was the command you typed in to get wallet running?

droid-wallet-cli

A) you aren’t synced all the way with the network and so wallet registration & mining won’t work.
B) There are three ways to get the blockchain

  1. Slow and decentralized, just run derod until it catches up
  2. Faster but centralized, delete mainnet folder then run “rsync --inplace --port=2048 -a rsync://141.95.86.80/DEROblockchainDB/mainnet ./”
  3. Fastest, but pruned: delete mainnet folder and run derod with “–fastsync”
1 Like

thanks how much is total size of mainnet directory?

she big
I tried to fit unpruned on my 36GB pixel
no dice, too big
practically bricked my phone
Go with pruned, or run the daemon on a separate machine and point your miners at that.

1 Like

How much is prune size?

1 Like

19/06 14:32:46 INFO CORE Chain Pruned till {"topoheight": 501432}
DERO HE: 538329/538329 [538329/538329]
My mainnet file is 1.1 GiBwith the 500000+ blocks without tx data and the 37000 blocks with tx data

So if I download third way . It only download 3gb and I can mine with my phone?

1 Like

you can run

./dero-miner-arm64 --wallet-address dero123address456 --daemon-rpc-address minernode1.dero.io:10100

you are now mining without full node.

now, this is podracing!

1 Like

So I just need run dero wallet and dero miner? No dero ? Just wallet and miner?

You can run the miner using the command I gave without wallet or derod running.

I still just get error

Try with 45.82.66.54:10100 instead of minernode1.dero.io ; this is the resolved ip of that address. Sometimes mobile termux sessions can’t resolve the name.

2 Likes


It seems it works now thanks

1 Like

image
After 4hour

1 Like

Yup. High emissions and low nw hash is money in the bank.