Cant seem to Sync my Daemon!

So as u read from topic name, I have been trying to Set up a node for my miners, Trying to follow the Guide Creating a DERO Home Network — DERO Documentation documentation, I have an issue with the first step as I ran Derod
from CMD using this Command Line:
derod-windows-amd64.exe --add-priority-node=45.82.66.54:8080 --p2p-bind=0.0.0.0:56456 --debug
(Version: 3.4.138-49.DEROHE.STARGATE+10032022)
,but I got this issue where Daemon didn’t wanna sync as the following Image
(https://media.discordapp.net/attachments/419781880632836098/952731748616253460/unknown.png?width=1395&height=614)

, Then I started asking for help from Discord community and I started following their advices (Deleted Mainnet and restarted PC after every step of the following):

  1. I used a Time Sync application (https:// timesynctool .com/)
    (https:// images-ext-2.discordapp .net/external/A_AxXKSxpJsUgyLCl5njSpajO8M81CWq8ANrHx5dyAc/https/media.discordapp.net/attachments/419781880632836098/953901771552587806/unknown.png) [Remove Spaces for the link to work]

  2. Closed Firewall, Allowed apps through Firewall as-well (just to be sure)
    (https:// media.discordapp .net/attachments/599432136440807435/954067855966621826/unknown.png?width=870&height=617) [Remove Spaces for the link to work]

  3. Forwarded Port 56456 in router (Bec. it is used in --p2p-bind=0.0.0.0:56456)

  4. Opened Ports in windows as-well (these ports I saw being used in Derod Connection)
    (https:// media.discordapp .net/attachments/599432136440807435/954067656175157278/unknown.png?width=1395&height=519) [Remove Spaces for the link to work]

  5. Checked UDP traffic as Captain mentioned.
    -Downloaded NetCat on 2 Devices(Main PC and a laptop)
    -Ran CMD with nc -u -l -p 2000 (on main PC)
    -Ran CMD with nc -u serverIP_of_First_cmd 2000 (on laptop)
    -Started texting from both devices and text was being sent without any problem
    (https:// media.discordapp .net/attachments/953174008206077972/953703870427725824/unknown.png) [Remove Spaces for the link to work]


yesterday, After checking all these steps again, I just left the Derod on and went AFK for 2 hours coming back to find that Daemon started Syncing, then after 10 mins it stopped and repeated the old problem(Purging connection due since idle & backing off from this connection)

After some talking with some members from community without any help I went to sleep, waking up with Daemon synced up to 21867/21867 then started issue again, Then I went to work and came back to it at 79769/79769, Till now I don’t know how to solve this issue, where Daemon just keeps stopping from syncing. Even if I wait for it to fully sync, I wont be able to set up my own node, as connection stops for very long time till it starts re-syncing.

I am very sorry for the very long Topic, But I wanted to mention most of the steps I did, to not waste Your time in suggesting things that I might have already done. Thanks in advance for helping :slight_smile: and sorry for my bad English.

1 Like

Ttry runnig derod daemon with --add-exclusive-node=45.82.66.54:8080 and report.

i typed : derod-windows-amd64.exe --p2p-bind=0.0.0.0:56456 --add-exclusive-node=45.82.66.54:8080

but still same issue

Try latest release Releases · deroproject/derohe · GitHub

tried it and still same issue !!

Version: 3.4.141-50.DEROHE.STARGATE+18032022

Your machine doesn’t like the seed nodes.
There was an incoming connection (103.4.92.6:57518) which worked for you.

Start your daemon with option
–add-exclusive-node=85.214.253.170:40348
Let’s see if your machine wants to synchronize with my node.

so after some testing I realized that if I used mobile data as source of internet connection , the daemon works without any problem, But when I switch back to my Router connection it gets back to the issue.

mmarcel, I tried your solution , but it is still the same

Can you check your router/firewall to allow and increase UDP connections limits.