Daemon still stuck at block (even after resyncing, deleting p2pstate.bin and downloading the latest binaries)



Daemon stuck at block 39338 after adding a bunch of alternative blocks, connected to over 15 peers.


pls see here DERO blockchain sync problem
Try downloading and replacing data.mdb from here.


Deleting the blockchain folder and re-sync did not help. The daemon stucks at the block 39338.


I did have that issue, I just waited few hours and when I checked back it was synced normally


There were a couple sync issues today that I ran into myself. Like Mojo, I had success by leaving my daemon open for a while and when I came back it was correctly synced.

Support is aware of the problem and is actively addressing it in the golang rewrite. At this point they’re quite close to finishing their current stage of development and a fix on the original code is probably not necessary at this point in the golang development!

Dero GUI Wallet

What is the current size of data.mdb ? I downloaded it from http://seeds.dero.io/data.mdb , it was ~2.3 Gb. Then I replaced my old data.mdb by a new one, then I started the Derod.exe . It is synchronizing now: 34501/39943 (86.4%) , but the size of data.mdb increased already up to 4.22 Gb. Is it Ok ?


Can you report back after it has fully synced and you’ve had a chance to save the blockchain?

The size of the up to date data file is around 2.4GB today


Serena, thank you for the reply ! Finally my daemon synchronized correctly, the -cli wallet shows correct balance, but the data.mdb is ~4.67Gb instead of ~2.4Gb. So, after I copied the data from http://seeds.dero.io/data.mdb and started my Derod, it looks like the Derod added the whole blockchain on the top of the copied data.mdb. Before I tried to delete data.mdb and re-synced from the scratch, but in this case the daemon stucked at the block 39338. Maybe it worth trying again ? Hopefully, when a new golang daemon is ready, it will re-load the whole blockchain smoothly.


Hi Mik,

Block 39338 seems to be causing a few people, including myself, a synchronization error. I followed many of the same steps you did and ultimately I left the blockchain alone for a few hours, came back, and it was fully synced.

We understand that this is less than ideal and there is a solution ready for the golang implementation.

It’s been a hectic day so far, so I apologize if I’ve already asked you this. Did you backup your wallet files and delete all of your dero folders (Programdata and the extracted folder) followed by a computer restart?

I just helped another member with the same issue who successfully synced just now using the data found here: DERO blockchain sync problem

I understand that this is likely the same data you’ve downloaded, however, clearing all existing data (except your wallet files) and starting from scratch appears to be working as I’ve had positive reports rolling in for a little while now. Also, please remember to restart your computer to clear your temporary memory before starting fresh.

The development team is definitely aware of this issue and has a fix for the golang version.


Already tried that, still doesnt work


A similar problem. Also stuck on the block 39338. As a result, the found block is orphaned.


Solved all. Post if not.


Hi there!
Got the sync problem, so already downloaded windows binary from http://seeds.dero.io/build/dero_windows_amd64.zip on a new windows installation, ( so, synch from the beginning) but it got stuck at #39325.
Daemon keeps saying a lot:

WARN[1019] Prev_Hash  no where in the chain, skipping it till we get a parent 
 blid=6d97cb086737d0388400c6b35eb2fbcf6b3829094e2bd82c09978fc152f58485 com=BLKCHAIN

Couldn’t find a data.mdb All I have is a file called dedrod_database.db at c:\Users\MyUser\AppData\Local\Temp

Any idea? Thanks!


Hello maxeprom,

Can you try downloading this version (https://github.com/deroproject/dero/releases/download/v0.11.6/dero_v6_windows_amd64.zip)

Your data should be saved in c:\programdata\dero though you will need to use the “Save” command in the daemon before exiting.

If you’ve got any data in that folder now, please delete p2pstate.bin and the imbd folder, restart your computer, and start with the daemon from the link provided above

If you still have any issues, please let me know and I will help you sort it out :slight_smile:


Hi Serena,

Thank you, I’m on that. Will take some time to synch, so I’ll keep in touch later to confirm.