DERO blockchain sync problem


#42

cheers i forget about the time differances!!!, only been into crypto stuff a few weeks, but learning a lot, (still loads out there) when the new alpha finishes syncing will i be able to use a command the same as before to start solo mining? cant see the command listed under help? or is it best to keep on the older v6 version of derod?
cheers for understanding…


#43

I don’t believe that you can currently mine with the new golang version but feel free to poke around and provide any feedback you’d like. If you post it here our developers will read it :slightly_smiling_face:


#44

cheers
i assume this is normal from what i seen on the new version.


#45

Im still getting a few sync problems or maybe its not me its who im syncing from? got a few banned ip addresses.

Just if this helps!!


#46

Thank you!

There’s no need to worry, those warnings are fine. The golang version is in debug mode (for now) so it will show a lot of extra data you wouldn’t normally see. The old daemon is okay as well but we’re almost done with that one. I’ll keep the community up to date to let everyone know when the switch is required

I’m on the golang version myself and it works great!


#47

new one does seem better.


#48

I’m using windows gui and im stuck at 51314/53102 (96%).


#49

The windows GUI wallet is maintained by a community member but at this time it appears that it’s not working for some people. We strongly recommend everyone moves over to the new golang version of Dero.

We’re ready for all individual users to start migrating to (http://seeds.dero.io/alpha/)

We ask the all pool and exchange operators wait for the next release.


#50

Oh so I have to download again the blockchain. Back to zero.


#51

Is this normal?
image


#52

Yeah, Debug extra logs/warning will go after full sync.


#53

Just to ask, in case anyone else solo mines, whats the best approach at the moment. as my older windows v6 version is still not syncing past 52402, but the new golang is at 53208? I do solo mine using derod.exe on one machine.

for all - feedback, new alpha/golang seems to be good and fine, syncing completed in a few hours with no errors apart from the debug stuff mentioned already above. wallet also nicer.


#54

Solo mining is not useful with current NW hash, its mostly good in the beginning.
Golang wallet doesn’t support mining. Either you use v7 linux daemon/wallet for solo mining. Or pls compile from source for windows.
It would be much better if you can join any pool For Eg: http://pool.dero.live/#getting_started


#55

Yeah i joined a pool, for a couple of low power machines, but i have one slightly better. just thought id try my luck! (had a bit of success) thanks for your reply.


#56

I am trying to build a Dero node on Linux, but it will not even begin to sync. I ran the following having used sudo -i to assume root role

git clone https://github.com/deroproject/dero dero
cd dero
make
cd build/release/src
mkdir /opt/dero/
cp /root/dero/build/release/bin/* /opt/dero
/opt/dero/derod

It launches fine, goes through some initialization then gives me the following four lines
2018-04-03 15:44:08.258 [P2P1] WARN global src/cryptonote_core/cryptonote_core.cpp:1282 **********************************************************************
2018-04-03 15:44:08.281 [P2P1] WARN global src/cryptonote_core/cryptonote_core.cpp:1283 Last scheduled hard fork time shows a daemon update is needed now.
2018-04-03 15:44:08.281 [P2P1] WARN global src/cryptonote_core/cryptonote_core.cpp:1284 **********************************************************************
2018-04-03 15:44:08.457 [P2P1] WARN net.dns src/common/dns_utils.cpp:487 WARNING: no two valid DeroPulse DNS checkpoint records were received

I have left it for 1 hour and it has not budged a bit - any ideas? I have only just built it, so I assume the repository is up-to-date

Thanks


#57

Just seen the notice re the new post 2/4 daemon. Will try that. Please ignore the above reply

Edit - Just to finish this off in case anyone else comes here and finds this, the new daemon appears to be working fine. I did chage the daemon name to just derod though, the given name is far too long …


#58

Thanks for the feedback deroguy, it has been noted and appreciated!

Just to be extra safe, can you please make sure you’re on the latest version here: http://seeds.dero.io/alpha/


#59

I used wget http://seeds.dero.io/alpha/, so I am pretty sure it is the latest version as of about 1 hour ago


#60

I think you’re probably on the correct version if that’s the case :slightly_smiling_face:


#61