DERO pool connection is always Dead


#1

Hello,

Im trying to setup my dero pool. Pool was installed, and everything looks good, but miners cant connect to any port. Always status is “Dead”.
My installed software is Dero-linux-amd64 ( DERO Atlantis Version 2.0.1-2.alpha.atlantis+29062018 ). I have renamed files derod-linux-amd64 dero-wallet-cli-linux-amd64 and explorer-linux-amd64 to derod dero-wallet-cli and explorer. Maybe there is my mistake?

I have attached pool config file in PDF format, please take a look… Please help!
Thank you!

{
"poolHost": "My_Pool",

"coin": "dero",
"symbol": "DERO",
"coinUnits": 1000000000000,
"coinDecimalPlaces": 4,
"coinDifficultyTarget": 12,

"daemonType": "default",
"cnAlgorithm": "cryptonight",
"cnVariant": 0,
"cnBlobType": 0,

"logging": {
    "files": {
        "level": "error",
        "directory": "logs",
        "flushInterval": 5
    },
    "console": {
        "level": "info",
        "colors": true
    }
},

"poolServer": {
    "enabled": true,
    "clusterForks": 6,
    "poolAddress": "My_Wallet_address",
    "intAddressPrefix": [
                      "823000",
                      "446296"
                        ],
    "blockRefreshInterval": 1000,
    "minerTimeout": 900,
    "sslCert": "./cert.pem",
    "sslKey": "./privkey.pem",
    "sslCA": "./chain.pem",
    "ports": [
        {
            "port": 3333,
            "difficulty": 5000,
            "desc": "Low end hardware",
            "hidden": true
        },
        {
            "port": 4444,
            "difficulty": 15000,
            "desc": "Mid range hardware",
            "hidden": true
        },
        {
            "port": 5555,
            "difficulty": 50000,
            "desc": "High end hardware"
        },
        {
            "port": 7777,
            "difficulty": 500000,
            "desc": "Cloud-mining / NiceHash"
        },
        {
            "port": 8888,
            "difficulty": 5000000,
            "desc": "ASIC",
            "hidden": false
        },
        {
            "port": 9999,
            "difficulty": 20000,
            "desc": "SSL connection",
            "ssl": false,
            "hidden": false
        }
    ],
    "varDiff": {
        "minDiff": 100,
        "maxDiff": 100000000,
        "targetTime": 60,
        "retargetTime": 30,
        "variancePercent": 30,
        "maxJump": 100
    },
    "paymentId": {
        "addressSeparator": "+"
    },
    "fixedDiff": {
        "enabled": true,
        "addressSeparator": "."
    },
    "shareTrust": {
        "enabled": true,
        "min": 60,
        "stepDown": 3,
        "threshold": 10,
        "penalty": 30
    },
    "banning": {
        "enabled": true,
        "time": 600,
        "invalidPercent": 25,
        "checkThreshold": 30
    },
    "slushMining": {
        "enabled": false,
        "weight": 300,
        "blockTime": 60,
        "lastBlockCheckRate": 1
     }
},

"payments": {
    "enabled": true,
    "interval": 3000,
    "maxAddresses": 6,
    "mixin": 7,
    "priority": 0,
    "transferFee": 79812400000,
    "dynamicTransferFee": false,
    "minerPayFee" : false,
    "minPayment": 1000000000000,
    "maxPayment": null,
    "maxTransactionAmount": 0,
    "denomination": 10000000000
},

"blockUnlocker": {
    "enabled": true,
    "interval": 30,
    "depth": 60,
    "poolFee": 0.9,
    "devDonation": 0.0,
    "networkFee": 0.0
},

"api": {
    "enabled": true,
    "hashrateWindow": 600,
    "updateInterval": 5,
    "bindIp": "0.0.0.0",
    "port": 8117,
    "blocks": 30,
    "payments": 30,
    "password": "your_password",
    "ssl": false,
    "sslPort": 8119,
    "sslCert": "./cert.pem",
    "sslKey": "./privkey.pem",
    "sslCA": "./chain.pem",
    "trustProxyIP": true
},

"daemon": {
    "host": "127.0.0.1",
    "port": 20206
},

"wallet": {
    "host": "127.0.0.1",
    "port": 20209
},

"redis": {
    "host": "127.0.0.1",
    "port": 6379,
    "auth": null,
    "db": 0,
    "cleanupInterval": 15
},

"notifications": {
    "emailTemplate": "email_templates/default.txt",
    "emailSubject": {
        "emailAdded": "Your email was registered",
        "workerConnected": "Worker %WORKER_NAME% connected",
        "workerTimeout": "Worker %WORKER_NAME% stopped hashing",
        "workerBanned": "Worker %WORKER_NAME% banned",
        "blockFound": "Block %HEIGHT% found !",
        "blockUnlocked": "Block %HEIGHT% unlocked !",
        "blockOrphaned": "Block %HEIGHT% orphaned !",
        "payment": "We sent you a payment !"
    },
    "emailMessage": {
        "emailAdded": "Your email has been registered to receive pool notifications.",
        "workerConnected": "Your worker %WORKER_NAME% for address %MINER% is now connected from ip %IP%.",
        "workerTimeout": "Your worker %WORKER_NAME% for address %MINER% has stopped submitting hashes on %LAST_HASH%.",
        "workerBanned": "Your worker %WORKER_NAME% for address %MINER% has been banned.",
        "blockFound": "Block found at height %HEIGHT% by miner %MINER% on %TIME%. Waiting maturity.",
        "blockUnlocked": "Block mined at height %HEIGHT% with %REWARD% and %EFFORT% effort on %TIME%.",
        "blockOrphaned": "Block orphaned at height %HEIGHT% :(",
        "payment": "A payment of %AMOUNT% has been sent to %ADDRESS% wallet."
    },
    "telegramMessage": {
        "workerConnected": "Your worker _%WORKER_NAME%_ for address _%MINER%_ is now connected from ip _%IP%_.",
        "workerTimeout": "Your worker _%WORKER_NAME%_ for address _%MINER%_ has stopped submitting hashes on _%LAST_HASH%_.",
        "workerBanned": "Your worker _%WORKER_NAME%_ for address _%MINER%_ has been banned.",
        "blockFound": "*Block found at height* _%HEIGHT%_ *by miner* _%MINER%_*! Waiting maturity.*",
        "blockUnlocked": "*Block mined at height* _%HEIGHT%_ *with* _%REWARD%_ *and* _%EFFORT%_ *effort on* _%TIME%_*.*",
        "blockOrphaned": "*Block orphaned at height* _%HEIGHT%_ *:(*",
        "payment": "A payment of _%AMOUNT%_ has been sent."
    }
},

"email": {
    "enabled": false,
    "fromAddress": "your@email.com",
    "transport": "sendmail",
    "sendmail": {
        "path": "/usr/sbin/sendmail"
    },
    "smtp": {
        "host": "smtp.example.com",
        "port": 587,
        "secure": false,
        "auth": {
            "user": "username",
            "pass": "password"
        },
        "tls": {
            "rejectUnauthorized": false
        }
    },
    "mailgun": {
        "key": "your-private-key",
        "domain": "mg.yourdomain"
    }
},

"telegram": {
    "enabled": false,
    "botName": "",
    "token": "",
    "channel": "",
    "channelStats": {
        "enabled": false,
        "interval": 30
    },
    "botCommands": {
        "stats": "/stats",
        "report": "/report",
        "notify": "/notify",
        "blocks": "/blocks"
    }
},

"monitoring": {
    "daemon": {
        "checkInterval": 60,
        "rpcMethod": "getblockcount"
    },
    "wallet": {
        "checkInterval": 60,
        "rpcMethod": "getbalance"
    }
},

"prices": {
    "source": "tradeogre",
    "currency": "USD"
}

,
“charts”: {
“pool”: {
“hashrate”: {
“enabled”: true,
“updateInterval”: 60,
“stepInterval”: 1800,
“maximumPeriod”: 86400
},
“miners”: {
“enabled”: true,
“updateInterval”: 60,
“stepInterval”: 1800,
“maximumPeriod”: 86400
},
“workers”: {
“enabled”: true,
“updateInterval”: 60,
“stepInterval”: 1800,
“maximumPeriod”: 86400
},
“difficulty”: {
“enabled”: true,
“updateInterval”: 1800,
“stepInterval”: 10800,
“maximumPeriod”: 604800
},
“price”: {
“enabled”: true,
“updateInterval”: 1800,
“stepInterval”: 10800,
“maximumPeriod”: 604800
},
“profit”: {
“enabled”: true,
“updateInterval”: 1800,
“stepInterval”: 10800,
“maximumPeriod”: 604800
}
},
“user”: {
“hashrate”: {
“enabled”: true,
“updateInterval”: 180,
“stepInterval”: 1800,
“maximumPeriod”: 86400
},
“payments”: {
“enabled”: true
}
},
“blocks”: {
“enabled”: true,
“days”: 30
}
}
}


#2

Please post the same in slack support @Mojo


#3

Not related

If the daemon is fully synced, please get a professional to help you set up your pool, or join our social channels to see if someone would volunteer to help :slight_smile:


#4

Tha daemon is fully synced… Please take a look: http://poolway.pw/dero/
:slight_smile: Or connect: http://poolway.pw/dero/#getting_started


#5

I’ve been looking for help everywhere and can not find anywhere. This forum is my last hope :slight_smile:


#6

No worries , There are lots of people to help you. I am also not that good with setting up pool and stuff. but I am asking help from @Mojo


#7

Make sure your code follows modifications done to pool software as shown in


#8

if that doesn’t work please post the exact error message you are receiving.


#9

Yes, I have checked step by step this config…
My config is:
“coin”: “dero”,
“symbol”: “DERO”,
“coinUnits”: 1000000000000,
“coinDecimalPlaces”: 4,
“coinDifficultyTarget”: 12,

"daemonType": "default",
"cnAlgorithm": "cryptonight",
"cnVariant": 0,
"cnBlobType": 0,

"logging": {
    "files": {
        "level": "error",
        "directory": "logs",
        "flushInterval": 5
    },
    "console": {
        "level": "info",
        "colors": true
    }
},

"poolServer": {
    "enabled": true,
    "clusterForks": 6,
    "poolAddress": "dERoY2V8xk7fYpwdAsm5YxTray5ZnKVoT6PiQA7LWQn31tgS3zBCSS31EtyJ83A3gHc8zvqDZmjrsNehuaZgvMEc1bSChkyGus",
    "intAddressPrefix": [ "659160",
                          "823000",
                          "446296"
                         ],
    "blockRefreshInterval": 1000,
    "minerTimeout": 900,
    "sslCert": "./cert.pem",
    "sslKey": "./privkey.pem",
    "sslCA": "./chain.pem",
    "ports": [
        {
            "port": 25,
            "difficulty": 5000,
            "desc": "Low end hardware",
            "hidden": false
        },
        {
            "port": 5555,
            "difficulty": 50000,
            "desc": "High end hardware"
        },
        {
            "port": 7777,
            "difficulty": 500000,
            "desc": "Cloud-mining / NiceHash"
        },
        {
            "port": 8888,
            "difficulty": 5000000,
            "desc": "ASIC",
            "hidden": false
        },
        {
            "port": 9999,
            "difficulty": 20000,
            "ssl": false,
            "hidden": false
        }
    ],
    "varDiff": {
        "minDiff": 3400,
        "maxDiff": 100000000,
        "targetTime": 3,
        "retargetTime": 33,
        "variancePercent": 20,
        "maxJump": 50000
    },
    "paymentId": {
        "addressSeparator": "+"
    },
    "fixedDiff": {
        "enabled": true,
        "addressSeparator": "."
    },
    "shareTrust": {
        "enabled": true,
        "min": 10,
        "stepDown": 3,
        "threshold": 10,
        "penalty": 30
    },
    "banning": {
        "enabled": true,
        "time": 600,
        "invalidPercent": 35,
        "checkThreshold": 40
    },
    "slushMining": {
        "enabled": false,
        "weight": 300,
        "blockTime": 60,
        "lastBlockCheckRate": 1
     }
},

"payments": {
    "enabled": true,
    "interval": 3000,
    "maxAddresses": 6,
    "mixin": 7,
    "priority": 0,
    "transferFee": 79812400000,
    "minerPayFee" : true,
    "minPayment": 1000000000000,
    "maxPayment": null,
    "maxTransactionAmount": 0,
    "denomination": 10000000000
},

"blockUnlocker": {
    "enabled": true,
    "interval": 30,
    "depth": 60,
    "poolFee": 0,
    "devDonation": 0,
    "networkFee": 0
},

"api": {
    "enabled": true,
    "hashrateWindow": 600,
    "updateInterval": 5,
    "bindIp": "0.0.0.0",
    "port": 8117,
    "blocks": 30,
    "payments": 30,
    "password": "your_password",
    "ssl": false,
    "sslPort": 8119,
    "sslCert": "./cert.pem",
    "sslKey": "./privkey.pem",
    "sslCA": "./chain.pem",
    "trustProxyIP": true
},

"daemon": {
    "host": "127.0.0.1",
    "port": 20206
},

"wallet": {
    "host": "127.0.0.1",
    "port": 20209
},

and …


#10

There are no errors (or I do not see), just simple miners cant connect to pool… Pool always shown as “Dead” :frowning:


#11

Not just config, pool software.

lib/pool.js and lib/blockUnlocker.js

Or just use official pool, already optimized and 0.1% fees
http://pool.dero.live


#12

Thank you for help
but Im using “cryptonote-nodejs-pool”…
Maybe someone has fixed this file:


and can share it? :slight_smile:


#13

A lot asked for the same, then they fixed it and never shared it themselves :slight_smile: