How to mine DERO with Ubuntu


Hi, I am trying to start mining DERO, very interested in the project!

I am running Ubuntu 16.04.3, with i7 and 8gb RAM.

I have looked for a guide on how to set up the miner and couldn’t find much apart from this;

However this is for Monero. I followed the tutorial and installed the cpuminer-multi but i’m not sure how to use this to mine for DERO.

I can do the basics in linux but can’t quite figure out how to do this.

Can anyone help me please?

Cheers, deroman


Hello deroman,

You are able to mine Dero using the same programs you would use to mine Monero. I’m not familiar with the program that you’re trying to use, but I can recommend one for your consideration.




support all common backends (CPU/x86, AMD-GPU and NVIDIA-GPU)

support all common OS (Linux, Windows and MacOS)

supports algorithm cryptonight for Monero (XMR) and cryptonight-light (AEON)

easy to use

guided start (no need to edit a config file for the first start)

auto configuration for each backend

open source software (GPLv3)

TLS support

HTML statistics

JSON API for monitoring


If you require any assistance I’m available on several platforms to help you with any issues you may have related to Dero. The xmr-stak program is what I use myself for mining and I have enjoyed it so far.


hey Serena,

thanks for your reply!

I believe that is the program I am running is cpuminer-multi, I used the following command;

git clone
cd cpuminer-multi

Like I said I just followed that tutorial I linked to. Is xmr-stak a better option? Just I read somewhere cpuminer-multi was better for linux, but I really have no idea.

I have set up a monero wallet and started mining using the following command;

sudo ./minerd -a cryptonight -o stratum+tcp://MININGPOOL:PORT -u WALLET_ADDRESS -p MINER_NAME

Am I correct in saying that if instead of entering a monero wallet address and mining pool, I enter a dero wallet address and miningpool?

Thanks for your help, i’m always happy to learn more!


Hi deroman,

You’re very welcome for the reply, it was my pleasure.

I can’t honestly tell you which program is better because I have not used cpuminer-multi. I can say from personal experience that xmr-stak has worked well for me and seems to have a solid group of followers/developers.

You are correct, instead of using the monero address and pool you use a Dero wallet/pool.

Again, it was genuinely my pleasure, you’re very welcome. :smiley:


great, i’ll have a play around and try and get something working!

cheers, deroman


Serena, I got it working! I am now mining DERO in the official DERO pool :slightly_smiling_face:



I’m super happy to hear that deroman!!!

Thank you for being part of our community, supporting our network, and your exceptional politeness.

I’m looking forward to seeing you around any time you feel like popping in with questions, feedback, or just to say hello and converse.


(feel free to join us on Slack if you’d like, but no pressure!)


ha, I may have spoken too soon!

How do I actually know, if I have been accepted into the pool, if that is the right phrase to use.

On my terminal I have;

Using JSON-RPC2.0
Starting stratum on POOLNAME
3 miner threads started, using cryptonight

stratum detected new block
stratum detected new block

and many more ‘stratum detected new block’

very sorry for the noob questions but am I all good here, am I mining in the pool?

Thanks Serena



The first time you start your xmr-stak miner you have to close it afterwards. What it’s doing the first time is creating the config files for you to edit and some other relevant data.


Hi Serena! So I was using this multicpu-miner but installed the xmr-stak instead

It prompted me to change the config file which I did. I set the pool address to the right one and put my wallet address in.

I then run ./xmr-stak

is it now where I need to close it and run it again?

I have done that, and I seem to be connected to the pool.

I press c and it gives me connection info, and if I press H it gives me my hashrate I think, or maybe just the hashrate of the pool.

thanks for this help, really do appreciate it, I think I am really close to have this working



Hi deroman,

Sorry for my delayed response, I had to step away briefly.

If when you press C it shows your connection info including the pool, good shares, latency, and other good stuff then you are connected!

Using H will show your hashrate on your side. When you check the pool it’s just checking the number of shares you’ve sent and dividing it by the time you spent connected to give you an estimated hashrate.

I can’t recommend a specific cpu configuration, but you may be able to go online to get a little more hashing power out of your specific setup.

I’m really glad to hear that you got it up and running, congratulations!!


(Keep following up as needed)


Hi Serena,

no problem I had to go to sleep anyway.

I left it on over night and it seems to be working…

when I press ‘c’ I get;

Pool address
Connected since
pool ping time

Is this correct?

Also, how do I check the balance of my wallet? Do i use the view only wallet key, but where do I put that key?

Thanks so much for your help



Hi deroman,

It sounds like it’s working to me :slight_smile:

If you check out this guide it will tell you how to check your balance near the bottom. You will need to sync your daemon before loading your wallet. I’ll still be up for a couple hours at least so if you need any assistance just let me know!



Thanks Serena,

I’m just in work now so can’t actually do anything until later myself.

I am a bit worried as when I opened the wallet, I don’t think I synced it to the blockchain as I don’t think I ran derod.

Does this mean my wallet is invalid, and the address i’ve been mining to is also invalid?

Anyway, not important now as I have to wait to finish work and i’m sure you need to sleep.

Speak soon



Hello deroman,

I live on the West Coast of Canada so it’s still pretty early here but when I’m fully functional I will look into this with you on your schedule. No pressure, I’m here whenever you’re ready!



No Problem Serena!

I’ll give you a shout in a couple of hours, from the West Coast of England!



Hi Serena,

So I have checked on my miner and everything still seems to be running fine, if I enter c, it still says connected etc

Now I created my wallet on my other laptop, which runs windows.

So I ran derod, then I opened the wallet. I entered my 25 word seed and then entered balance but I didn’t see anything?

There is a green number and a yellow number but they are both zero in the format;

000000000 : 00000000000

So I am not sure if that is saying my balance is zero? or is that something else?

Thanks for your help



So I went onto the pool website and inserted my address and got the following

So I guess everything is working?


Hi deroman,

Sorry for my delayed response, I’ve been making excellent progress on a few Dero related projects and the time got away from me.

You’re up and mining successfully! When your balance reaches 2.0 Dero you will receive a transfer directly to your wallet. After the pool transfers the balance it will be fully unlocked in your wallet after 10 blocks.



Thanks for your help Serena, just a shame about my hash rate :rofl: