Can't send dero from TradeOgre to wallet.dero.io

Hi all - I’ve got some dero sitting in my TradeOgre account. I set up a Stargate web wallet and have made several attempts to transfer some dero from TradeOgre to the wallet. The sends all failed within a matter of seconds after being initiated. There are no hopeful error messages other than ‘failed’.

The wallet is online according to the indicator at the top of the screen. I’ve read some threads about this issue where others have mentioned that wallet registration needs to complete before you can send / receive. It’s been a couple of hours since I created the wallet and I still cannot transfer dero to it. I have no idea how to check registration status, the ‘Registration’ screen just says it must be registered and has a ‘Register now’ button that does not appear to do anything when clicked.

Appreciate any help or suggestions.

Thx

Register your wallet first.
Pls see Create-Register/Restore wallet on DERO Stargate Network

Those instructions only cover the CLI wallet, I’m trying to use the web wallet. I’ve already gone to the ‘Registration’ screen, clicked the ‘Register now’ button several times (does not appear to do anything, no message or confirmation is displayed). That was 16 hours ago. Tried again to transfer some Dero from TradeOgre to the web wallet: failed.

Any other suggestions? What exactly is supposed to happen on that ‘Registration’ page? As of now it still just displays a message that says, ‘Registration to Blockchain is mandatory to use your account. It may take upto 1 hr.’ Some instructions for registration would be great.

Is there supposed to be a daemon address listed here?

image

Thx

Click register and wait several hrs in webwallet as webwallet wasm is single thread.
After registration 0 → current block height.

Had already tried that, but went ahead and tried it again, this time leaving the browser tab open to that page for 24 hours. No change. Current screenshot:

image

I did log out and back in again to ensure that the screen refreshed.

What else can be tried?

Just repeat the process again and click register.

That’s exactly what I did before - no effect. Clicking ‘register’ does nothing but put a highlight around the button - after waiting 24 hours, no change.

Let’s back up a bit - are there any known browser incompatibilities? What browser(s) has the web wallet been tested on?

Use Firefox, latest version. You can hit F12 to view developer options stating registration has started as well as viewing task manager or other process explorer to see CPU usage.

Web wallet uses WASM which is limited as it does not support, natively, multi-threading and will register much slower than through wallet cli and other processes.

The web wallet does not work for registering an address. Despite what others will tell you in here it does NOT work. I tried it with Firefox, Chrome, Brave, Safari & Edge on Mac (various OS’s) and Win 10. Latest version of all browsers - nada.

You hit the register button and you could leave the page open for a week and it will not register an address.

Maybe there is one weird combination of platform, browser and version that does work but I did not find it - I used 4 different computers in my tests.

Save yourself time and grab the cli wallet, start it with the --remote option and register your address on there. Then export your seed phrases into the web wallet and boom - you will have a working web wallet.

It’s the ONLY way to get the web wallet working with a new address - the register button does nothing!

Thanks for the candor, it’s really appreciated. Not a fan of Firefox (and why wouldn’t Brave be the browser of choice, I wonder).

Was trying to take the “easy” way but I’ll just take the plunge and learn to use the CLI wallet. Nice to know that the Dero team is having a good time trolling us with non-functional web mockups :wink:

It’s not that Firefox is the choice, but rather has the best WASM support. Which is what the web wallet is compiled in (go code), to all run locally (with exception to using a remote node , of course).

Agreed, CLI is the best approach with --remote. Perhaps in future mutli thread support can be there or we can put in some other options to assist, but it’s more an easy onboarding for anyone now who have registered wallets already. Registering a new wallet will work much faster locally via CLI with remote param as described above.

Hi Folks,
I’m in the same boat. Tried many times to send Dero from Tradeogre (TO) to Stargate wallet and Failed everytime. Tried varying amounts. Judging by above conversation, I should try Firefox as I am using Brave. Here is another possibility. With the current turmoil hand huge falls in crypto, TO is protecting their liquidity and withholding transactions until things calm down. Have been told this has happened on some occasions in the past. Could be wrong. Have used Brave in past with Atlantis Wallet and no problem.

Be sure that your wallet is registered. You’ll know that it is simply by restoring the seed and it shows the height being current (x/x) rather than not synced at all (0/x).

It’s recommended to register wallets via CLI at the moment running with --remote as it can utilize multiple threads. otherwise you can register on the web wallet, but expect it to take many hours due to the nature of WASM.

Hi nelbert442,
Thanks for your reply. Really appreciate it. When I downloaded wallet, tried following instructions from video regards -remote tacked on end of URL but did not work. Clicked on URL -shortcut and wallet loaded succesfully … or so I thought it seems.
Now when I look at GREEN line of command it reads … DERO WALLET 0/0 >>> … Is that the synced Topoheight figure ??? In other words it should be something like 267788 / 267788 if wallet is properly up to date sycn wise ???
If that is the case, what are the step by step things I need to do to sync the wallet once I open it ?? OR do I have to delete and start from scratch again ??
Thanks in advance. Ethoskiwi

Yeah correct. It should be two ‘-’ so --remote . Just Incase it isn’t, judging based on your message so let me know if not.

Hi Nelbert442,
Have followed instructions to the letter. Put in the --remote and wallet successfully downloaded BUT cannot withdraw DERO from Tradeogre (TO)…all I get is “Failed” straightaway. Now the wallet although registered has not synced as it reads in green …0/0 0.000000. Now I am no expert, but I am thinking that the 0/0 should be reading something like 266828 / 266828. I am guessing the 0.000000 is the amount of Dero in your account. So the big issue is, how do I get my CLI dero wallet synced so I can deposit Dero into it. Need some step by step instructions please.
Thanks in advance. Ethoskiwi

Pls see Create-Register/Restore wallet on DERO Stargate Network