Create-Register/Restore wallet on DERO Stargate Network

1] Download latest release
2] Setup and run DERO Node and wait for sync.

OR

Users can also start wallet with --remote option to use remote daemon instead of their local node ./dero-wallet-cli-linux-amd64 --wallet-file=testWallet1 --remote

3] Run wallet in another terminal

4] Press 2 or 3 to create new or restore old wallet. Choose wallet-file and set language,password etc.

5] Now you will have wallet screen similar to following:
walletRegisterStart

6] Press 4 in wallet now to register.
walletRegisteringProcess

7] Wait for few minutes to few hrs to complete registration process. This registration is one time activity and compulsory.

8] Successful registered wallet will look similar to following:
walletAfterRegisteration

NB:
1] Users can also start wallet with --remote option to use remote daemon instead of their local node ./dero-wallet-cli-linux-amd64 --wallet-file=testWallet1 --remote
2] Windows/MacOS users too have similar process just use appropriate files based on their operating systems.
3] Backup your seed in all case. You require only 25 words seed to recover your wallet.
4] DERO sent to unregistered address will not be received.
5] Darwin files are for Mac systems.

Alternate guides for wallet creation:
CLI Wallet User Guide (Stargate) — DERO Documentation documentation
[SOLUTION] Registering DERO Wallet On Linux (Probably works on Windows/Mac too idk)
Videos:
Storing DERO - Full Node & CLI Wallet Creation Guide - YouTube
Storing DERO - Remote Node & CLI Wallet Creation Guide - YouTube

Great did all that. But my wallet is still empty of the Dero that was there in my Web Wallet.
Also Menu is not the same as yours no 12, 13, 14, 15 menu options available after registering with recovery, and option 4 registration.
Do you have any other suggestions for me to recover the Dero coins that I had in my Web Wallet?

I’m running option 4 now to register. Seemed not to work on previous attempt. At this moment it’s still registering, and this has been going for many hours now.
A few hours later I have 0/0 0.0000. So it looks like all my Dero has disappeared?

Looks you are not connected to any daemon. Read above guide again.
You have to run daemon first or use --remote option in wallet.

I have the daemon running now. See what happens with registration this time.
CLI wallet automatically start not remote. I’ll have to start it again with --remote somehow,
I’ll try to figure that out later.

Running Daemon but still unable to register. Any other options? How do I get CLI darwin wallet to start in remote?

Do I shut down Daemon then add --remote to the .exe file?

Does this mean restored wallet from seed is empty of Dero?
dero1qy0 281153/281153 0.00000 >>>

Since this is a new created wallet from my seed, why is the new wallet empty of Dero?

Can’t it be rescanned? the new wallet is related to the seed?

I was running derod daemon and added --remote.

Nice upgrade to screw up the Hodler of Dero. Just a month or two ago Web Wallet worked fine. Then as of today Web Wallet wouldn’t accept my password. So I restored from seed but Wallet was empty of Dero.
Still trying to get this Darwin CLI wallet to recover from my seed. I thought recovering from seed restored all transactions to current?

Do you have any other options?

Not able to make any headway with restoring from seed on using darwin CLI on Mac wit derod daemo running. I can not register and remote that I tried didn’t work. Looks like my seed doesn’t restore to when I had Dero in wallet associated with seed. Lol.
Has my Dero been stolen? Or is your update full of bugs.
I should be able to restore to the state I had Dero coins a few months ago, by restoring with seed?

I’ve downloaded a new wallet via walletatlantis.dero.io. My seed used there seems to be restoring my previous wallet state.
I’ve been out of the loop for awhile. Now I know about the Altlantis to Stargate update.
Look like my previous Atlantis wallet was swapped with the new Stargate wallet. That’s why I was having login issues and seed restore problems.
Now I need to swap my Atlantis dero for Stargate dero.
I have Dero at TradeOgre. They’ll be automatically swapped to Stargate dero.

yes , They’ll be automatically swapped to Stargate dero.

Hi Support,
I have followed the CLI install to the letter. Whereas above you get
dero1qy8 0 /151221 0.00000 every time I load it I get
dero1qy 0 /0 0.000000
Now ! Know that I am pretty thick when it comes to following computer line code, etc BUT even I know that the wallet is never going to sync. Have added the - - remote and still the same old story. Have absolutely no idea what Remote Daemon means but from notes above the - - remote covers that one. So no idea on what Local Node means. So how do I get to download a CLI windows wallet which has the beginnings of the correct sync numbers like above.

0/0 means you are not connected to DERO NW.
Run your local daemon or Start wallet with --remote option.

Hi. As explained above, I have done exactly that (run start wallet with --remote). I have even deleted the CLI Dero program and downloaded a “fresh program” and started from scratch. Every time I get the above result along with the support instructions to keep doing the same ?. When I get a 0 / 123456 0.000000 appearing, I will be a happy chappy. Again, what do we do to remedy this impass ? Thanks in advance for your help.

Snip of downloaded Dero Folder and note --remote added.

Clicked on 6th one down to download ( dero-wallet-windows-amd64–remote )

Another download attempted using the lasted release as in point No. 1 at start of thread. (Release 74; sync issues and minor bugs fixes) . Here is the result. Same old story.

You’ve just renamed the wallet file with --remote. You need to make a shortcut to the file.

Create a shortcut that has a path of the CLI wallet file. Right click the shortcut and add --remote to the end of the shortcut target, after a space.

You can also just open command prompt or PowerShell etc. in the directory of your files and run the CLI with --remote

.\dero-wallet-cli-windows-amd64.exe --remote
1 Like